Discuss all things Remember The Milk.


Siri integration on iOS 12 does not work

ptroeger says:
The Siri integration on iOS 12 does not seem to work at all.

RTM is only targeted when the command sentence ends in "in RTM". In all other cases, Siri tries to use the Apple reminder app. This might be simply given by design.

Commands with "in RTM" at the end always result in a (Siri) error message, saying that "there is a problem with the application." I tried the different sample phrases from the help pages, all with the same result. The Siri permissions for RTM in the iOS settings are all activated, and there seems to be no setting in the app that is related to this.

Did anybody got Siri + RTM to work with iOS 12?
Posted at 11:00am on February 22, 2019
andrewski (Remember The Milk) says:
Hi ptroeger,
Thanks for getting in touch and reporting this issue. Sorry to hear about your experience with the Siri integration.

The "in/with RTM" phrase is necessary for Siri to push the spoken phrase to the Remember The Milk app.

However, the error you're encountering indicates that something else is happening. Let's see what we can find!

First, particularly if you just enabled this or just started noticing this behavior, you may want to restart your iPhone.

Then, if it continues, you may want to try syncing the iOS app (by swiping down in any view), confirming that everything is synced and updated (e.g. by looking in the web/desktop app), and then logging out.

Last, if logging out doesn't help, reinstalling it may be necessary.

Keep me posted on what you find!
Posted 2 years ago
(closed account) says:
I face the same issue on Siri. Everything is synced and logout didn’t work.
Posted 2 years ago
andrewski (Remember The Milk) says:
Hi kkupe,
Sorry to hear that hasn't helped for you. Would it be possible to contact us so we could look into this more with you?
Posted 2 years ago
This topic has now been closed automatically due to a lack of responses in the past 90 days.