Discuss all things Remember The Milk.


Windows 8.1 IE11 and the return-key

gordonwatts says:
I have IE11 and 8.1 installed on my RT tablet. The handling of the return key seems to be broken. I suspect this is because IE11 has changed its user-agent string and as a result old detection logic is no longer working.

Here is how to re-pro the problem:
1. Load up the RTM website and log in.
2. In the task entry area, type a new task.
3. Hit "return" to enter the task. Nothing happens.

I'm not aware of a work around (if there is one please let me know, as it makes the web site not-useful on my tablet).

BTW, the return key has long been an issue in IE on your site. In particular, there is one other issue which keeps catching me. To repro the problem (I've not tested this in 8.1/IE11 - only in IE10):

1. Select a task you want to edit.
2. select the tag list and start entering a new tag
3. Hit enter to take advantage of auto-complete.
- The whole web page reloads. If you'd typed other tags in the list they are list.

Many thanks for this site!!

P.S. I'm aware of one app in the store - it can't deal with large numbers of tasks.
Posted at 10:42pm on July 7, 2013
gordonwatts says:
I just tested the second issue in 8.1/IE11 - it works now! So in IE10 that is broken, but in IE11 it works. So if the first issue were corrected then I'd be a happy camper!
Posted 6 years ago
brendan says:
Hi gordonwatts,
Thanks very much for reporting this!

I'll get this added to our list to investigate so our engineers can take a look.
Posted 6 years ago
marianolores says:
The return-key issue can also be reproduced with IE 11.0.9431.0 running on Win 7 SP1
Posted 6 years ago
brendan says:
Hi marianolores,
Thanks for confirming this. I'll get this platform added to the report as well.
Posted 6 years ago
marianolores says:
I also found a workaround for this issue by using Alt+013 on the numeric pad instead of the return key. (again IE 11.0.9431.0 running on Win 7 SP1).
Posted 6 years ago
adamrakich says:
I don't know if you've just changed the build or something but as of yesterday I have the same issue on Opera!

Windows 7


Browser identification

Opera/9.80 (Windows NT 6.1; WOW64) Presto/2.12.388 Version/12.16
Posted 6 years ago
andrewski (Remember The Milk) says:
Hi adamrakich,
I've added this to our list to investigate; sorry for the inconvenience currently!
Posted 6 years ago
markmorton says:
I was just coming to report the Enter button had stopped working on Opera too.

Opera/9.80 (Macintosh; Intel Mac OS X 10.7.5) Presto/2.12.388 Version/12.16
Posted 6 years ago
sui258 says:
I can confirm I'm also getting this issue on Opera 12.16, specifically Opera/9.80 (Windows NT 6.1; WOW64) Presto/2.12.388 Version/12.16. Tried on two different computers and getting the same issue.

If I set Opera to mask itself as IE then the issue goes away. Thanks for the ALT 013 workaround :)
Posted 6 years ago
omar (Remember The Milk) says:
The original issue (Enter/Return on IE11) was resolved yesterday.

Unfortunately this broke Opera in a strange way because Opera patched our site in browser.js (starting at 12.10).

The patch is here:

Enter/return should now work again on Opera 12.10. :)
Posted 6 years ago
markmorton says:
It is for me. Many thanks Omar :)
Posted 6 years ago
This topic has now been closed automatically due to a lack of responses in the past 90 days.