Discuss all things Remember The Milk.


Duo MFA prompt breaks MacOS app

cbonhorst says:
We use shibboleth for integrated SSO with Google and it's been working fine for years. Now they have implemented a mandatory second factor via Duo security. The login screen now goes from "Login with Google" to our SSO landing page but then only loads a blank page where the Duo login should be. This is using either the M1 or x64 MacOS app. Any ideas if there is a workaround for this? Web login within the browser works fine.
Posted at 3:11pm on February 27, 2023
andrewski (Remember The Milk) says:
Hi cbonhorst,
Thanks for getting in touch and reporting this issue. Sorry to hear that!

You may want to make sure you have the latest version of the desktop app, available from our website.

The latest version should correct this exact issue, so I hope that helps for you! But if not, could you contact us so we could get some more specifics? Thanks! 💙
Posted 9 months ago
cbonhorst says:
Tried the 1.4.2 for Apple Silicon and still get the same thing. Here's the path and where it breaks.

Login with Google - OK
Google Sign-in w/ email - OK (Redirect to SAML SSO page)
SSO Login for College - OK (Redirect to DUO for MFA)
DUO MFA - Blank Page

I opened the developer tools and I have two errors:

jquery-postmessage.min.js?v=98c73:9 Uncaught ReferenceError: jQuery is not defined
at jquery-postmessage.min.js?v=98c73:9:776

Uncaught ReferenceError: jQuery is not defined
at 3609 (preauth.js?v=154e6:2:257858)
at __webpack_require__ (preauth.js?v=154e6:2:258117)
at 6651 (preauth.js?v=154e6:2:226771)
at __webpack_require__ (preauth.js?v=154e6:2:258117)
at preauth.js?v=154e6:2:258359
at preauth.js?v=154e6:2:258385
Posted 8 months ago
andrewski (Remember The Milk) says:
Hi cbonhorst,
Sorry that the update didn't help! We'll continue investigating this and I appreciate your updated details.

In the meantime, the web app should work in your browser, but please let me know if not or if we can help with anything else. 💙
Posted 7 months ago
This topic has now been closed automatically due to a lack of responses in the past 90 days.