Forums

Discuss all things Remember The Milk.

menu

Tasks with due time doesn't show up in smart list

johan.nilsson says:
Most of my tasks have a due date with only the date portion, but for some tasks I also make use of the time portion.

I have a smartlist which search criterium is "... and dueBefore:now ...". In the web app, everything works as expected, but on my Android phone, only the tasks without the time portion shows up.

I thought it may be some kind of timezone issue, but I can't find any timezone setting within the app. The timezone is correctly set up on my phone. It doesn't matter whether I set the due time on Android or the web app; this problem occurs either way.
Posted at 12:16pm on July 20, 2020
andrewski (Remember The Milk) says:
Hi johan.nilsson,
I wonder if there may be some specific interaction between the search terms and how they are interpreted between the apps. Sorry about that!

Can you post the full Smart List search or send it by email so we can help specifically?
Posted 1 year ago
johan.nilsson says:
Here is one of my smartlists that doesn't work.

(startBefore:now OR start:never) AND (dueBefore:now OR due:never OR tag:deadline) AND NOT (tag:block OR hasSubtasks:true OR list:Inbox) AND NOT tag:corona AND (list:"Flytt från Bergsgatan till Jaktstigen" OR list:RTM OR tag:viktigt)

So for example a task with no start date, a due date set to 1 hour ago and with the tag "viktigt" should be visible in the list.
Posted 1 year ago
andrewski (Remember The Milk) says:
Hi johan.nilsson,
Is it possible that a task is not matching the middle portion? For me as long as I add a task in a different list than Inbox it shows up in both apps.

It may help to try a simpler search to see if this behaves correctly:

(startBefore:now OR start:never) AND (dueBefore:now OR due:never OR tag:deadline) AND (list:"Flytt från Bergsgatan till Jaktstigen" OR list:RTM OR tag:viktigt)

Or keep me posted on what you find and we'll see what else we need to do!
Posted 1 year ago
johan.nilsson says:
Hi! Now it seems to work with the original search query. How strange. Perhaps it was some kind of weird cache issue with my phone. I deleted all app data and it seems to work after that. Thanks for your help!
Posted 1 year ago
This topic has now been closed automatically due to a lack of responses in the past 90 days.