Welcome!  English (US) Language Switcher

Email tasks -- I can't get it to work

redbarn says:

In settings, I set Inbox as my default list to remove the padlock icon. I sent a simple email per the given format to the supplied address...and nothing appears in my inbox.

I had the exact problem with backpackit.com, which is why I thought I'd give "milk" a try. Does anyone know what might be causing the problem?

I'm using webmail (yahoo and gmail), and windows xp. Thanks in advance.

Posted at 5:40am on December 28, 2005

redbarn says:

Something happened overnight while I was sleeping -- the reminders are in there. Patience is a virtue. Thanks anyway.

Posted 8 years ago

emily (Remember The Milk) says:

Glad it works for you :)

Tasks should appear in the Inbox within 1 minute, but occasionally mail delays will occur -- if you have any further problems with this feature, please let us know.

Posted 8 years ago

luc0zade says:

I couldn't get email tasks to work either until I started sending emails in a very strict format:-

1) Plain text, no html format emails.
2) No blank lines between the start of the email and the first line of text codewords.
3) Put each codeword/value pair on a separate line.
4) Put the codewords in this order: Due - Priority - List.
5) Remember not to enter the Due value as 'one week' or 'three days' - enter '1 week' or '3 days' instead.
6) Don't leave any of the fields empty.
7) Always put '---' on a separate underneath the codewords, before the remainder of the email.

Following these rules works every time for me, although sometimes you may have to refresh the page before they appear. Also, tasks destined for other lists may still briefly appear on the inbox tab when you first open RTM, but will instantly be transfered to the correct list if you try to click on them.

Posted 8 years ago

luc0zade says:

Sorry - CORRECTION - it seems you have to put the codeword fields in the order PRIORITY - DUE - LIST - i.e. Priority needs to be the first codeword/value pair.

Posted 8 years ago

jason.brown says:

I'm having trouble with this too.

Everything in the body of the email shows up as notes. The codewords are ignored, no matter what order I put them in.

Posted 8 years ago

luc0zade says:

I got this feature working by first sending the example email from the help page from my own email account to my own todo list, although I didn't bother with the repeat or estimate codewords - see http://www.rememberthemilk.com/help/answers/sending/emailinbox.rtm .

Once you get this working, you can amend the email to suit your own tasks.

My top two tips are (1) send only plain text emails and (2) be careful in your choice of values for 'Due'. Many of the more casual expressions which work when adding tasks via the website don't seem to work if they're used in emails. Stick to simple values like Monday / Tuesday / Wednesday.

Hope this helps.

Posted 8 years ago

jason.brown says:

Sending myself an exact copy of the example email has made the task attributes work. It's automagic!

However I still can't get lists of tasks to work -- each task just shows up as a line in a note...

Posted 8 years ago

emily (Remember The Milk) says:

Jason, can you please check that you're emailing your import email address (shown under Settings/Info)? This address contains '+import'.

If you're emailing this address and still having problems, please send us an example of a list of tasks that you're trying to email in ([old address removed]). We can look into this further. Thanks!

Posted 8 years ago

emily (Remember The Milk) says:

Just wanted to note that all due date formats that work on the website should work for emails too -- if you find something that doesn't work, please let us know so that we can look into it. Thanks!

Posted 8 years ago

This topic has now been closed automatically due to a lack of responses in the past 90 days.