Bonvenon!  Esperanto Language Switcher

Does Remember The Milk support my browser?

Remember The Milk is accessible via a PC, Mac, or Linux computer with one of the following fully supported browsers:

  • Firefox 3.0+
  • IE 7.0+
  • Opera 10.0+
  • Safari 5.0+
  • Google Chrome

For the best experience, we recommend using the latest version of Google Chrome, Firefox, Internet Explorer, or Safari.

A note regarding betas: We don't officially support beta or preview versions of browsers, as they can have bugs that aren't ironed out until the final version.

We recommend accessing Remember The Milk with a final version of your browser of choice, as we're unable to provide assistance for issues that may arise when using unsupported browsers.

Regardless of your browser type, you must have cookies and JavaScript enabled to use Remember The Milk.


Still need help? EmailContact a human