Welcome!  English (US) Language Switcher

GMail rule to forward to RMlik Inbox

klaasdepoel Pro says:

I've quickly browsed through the tips&tricks section to see if someone mentioned this, but I couldn't find in within 2 minutes of browsing, so here's my tip.

In Gmail you can use extensions, for example: mailaddress@gmail.com can be extended to mailaddress+todo@gmail.com

A filter can then be added in GMail to forward all mailaddress+todo@gmail to username+12345@rmilk.com (hey, same logic!)

So whaddayahave? A way to let other people add tasks to your list. Why, you ask? Well, I need tools for GTD, and my girlfriend reminds me every day about at least one thing. And yes, I forget this stuff. heheh. I now tell her to email it to me, using the extension and it will be on my list. :)

It's a dangerous tip, I realize, because it lets people spam your task list, but hey, change the extension/filter every now and then and it will be fine.

Posted at 6:07pm on December 22, 2007

erik Pro says:

I have been doing this for a while now and one way that I structure my RTM that helps this from becoming list "spam" is by using my rtm inbox only as a temporary staging list. Once I have something there I tag it and move to my normal list.

Anything in my rtm inbox is still not officially a task until I act on it.

Posted 6 years ago

jennifer.isaacs says:

I'm slightly confused how this works.
I noticed that upon emailing myself using:

username+todo@gmail.com

I receive the same email in my inbox (expected.)

I requested that gmail forward mail sent to:

username+todo@gmail.com

to the remember the milk email address.

However, it NEVER gets there!
What am I doing wrong?
Do I need to set up extensions with gmail first?

Please help :)

Posted 6 years ago

raymond.bergmark ProPower Poster says:

jennifer: Not that it helps you in any way, but testing like your setup worked perfectly for me. Even if Gmail was closed did this work. The delay could be measured in seconds.

Posted 6 years ago

jennifer.isaacs says:

I am quite frustrated.
I created a filter, such that

Matches: to:(gmailuser+todo@gmail.com)
Do this: Forward to rtmuser+strangenumbers@rmilk.com

In the forwarding settings, forwarding has been disabled. If I enable forwarding, it wants me to forward all of my mail to a certain address...which is NOT what I had wanted to do.

And, there is still no task in my task box twenty minutes later...
What am I doing wrong?

Posted 6 years ago

ranbarton ProPower Poster says:

My friends and family liked the idea of being able to add tasks to my to-do list, but they didn't like remembering another email address, so my Gmail rule matches emails from one of my approved task sends and a unique text string that people add to the body of the email. When those two conditions are met, gmail marks the email as read, skips the inbox, and forwards to RTM. Works all the time. Not sure what you are doing wrong.

Posted 6 years ago

klaasdepoel Pro says:

Jennifer,

My experience is, that gmail does something strange with the filters when you send an email to yourself. Perhaps this is something you tried. Perhaps you should test this through some other emailaccount.

Hope it helps. you can disable the forwarding part. It has nothing to do with this.

Klaas

Posted 6 years ago

jennifer.isaacs says:

Thank you so much everyone!

That helped.
Conclusively, anyone who is trying to test the filter should not try testing it by emailing it to oneself...it does not work. You must use another account, as Klaas said.

My set up was described as above, I instructed the filter to cause the message to skip the inbox and archive the message, and seconds later, it appeared in my RTM inbox!

Thank you!

Jennifer

Posted 6 years ago

Log in to post a reply.