Velkommen!  Norsk (Bokmål) Language Switcher

Tasks entered in Outlook do not sync to RTM

aaron.torgerson says:

I just installed MilkSync today, and it worked fine to import all of my tasks into Outlook 2007 (running on my 64-bit Windows Vista machine), but tasks that I enter into Outlook do not sync to RTM. Looking in the logs, I see that it seems to think that there were 0 changes to sync in Outlook.

Has anyone seen this / found a solution?

Posted at 2:37am on November 30, 2010

steven3ver says:

I have the same problem; tasks made in RTM appear in Outlook(2003) but not vice versa.

No solution found so far...

Posted 3 years ago

bakkulf says:

I use one-way syncing (Outlook -> RTM), and it seems all of my tasks are created in RTM. However, if I then do a change in Outlook, it's not always sending over the changes to RTM.

Posted 3 years ago

emily (Remember The Milk) says:

We'd love to check into this -- to anyone experiencing this issue, if you haven't done so already, could you please submit an issue report? Thanks!

Posted 3 years ago

rramos1207 says:

same is happening here. Have Outlook syncing one-way to RTM and won't sync any tasks.

Posted 3 years ago

andrewski (Remember The Milk) says:

rramos1207,
Would it be possible to submit a MilkSync for Microsoft Outlook issue report via our support system, if you haven't done so already?

Just select your issue from the list on the left, and follow the steps shown. If your issue isn't listed, click on "I'd like to report a new issue".

Your report should provide all the info that we need to investigate further, but we'll be in touch via email if we require any more details.

Thanks!

Posted 3 years ago

bluelake Pro says:

I have the same problem after every automatic upgrade of MilkSync!
As long as there is no upgrade, everything works fine.

After an upgrade I always have to do a clean remove / install of the software...

At least we should have an option "Recover from Outlook" which deletes all tasks in RTM and re-imports all tasks from Outlook to RTM.

Posted 3 years ago

andrewski (Remember The Milk) says:

bluelake,
It'd be great if you could submit an issue report as mentioned above; we'd love to take a look at what you're seeing.

Thanks!

Posted 3 years ago

prjh says:

OK, touch wood here's a workaround; it may be that not all the steps are essential but for completeness I'm not going to guess any shortcuts here. Thanks to bluelake for the hint.

1. In Outlook, create a new tasks folder - this will be a back up.
2. Move all of your active tasks from the main tasks folder to the new back up folder (for good measure you could also export to a pst file).
3. Close Outlook
4. Delete all tasks in RTM
5. Uninstall Milksync, reboot
6. Reinstall Milksync

Now, both Outlook and RTM have no tasks (except for the backup)

7. Right click on the tray icon, select Tools -> Restore and then OK.

Still no tasks!

8. Create a new task in RTM, e.g. "Test RTM -> Outlook"
9. Run Sync - you should see this in Outlook when you reload.
10. Amend the task in Outlook, e.g. "Test RTM-> Outlook, Amended"
11. Sync

At this point I saw my amended task appear in RTM - encouraging!

12. Then copy your tasks back from the back up folder to the main tasks folder in Outlook. I did this in batches, syncing after each.
13. Hurrah - Outlook "created" tasks are appearing in RTM
14. Test with a brand new task created in Outlook - also working here.

So, that seems to be a workaround.
But I would second a point a I've seen posted elsewhere - it would be great to have a 'restore' option that flattened RTM and kept Outlook as the master.

Good luck folks.

Posted 3 years ago

zeebacca says:

Before you RTM folks say a word, I just submitted my support request for this exact same issue. Thanks.

Now some feedback. Like so many others before me, I'm having the same issue. Might be a good idea for you guys to take a look at all the support requests related to syncing up to RTM to identify trends and similarities. Find the common driver, publish a post with a temporary fix, issue a new version of the software eventually.

I think of that as pro-active support; obviously asking people to submit support requests is what you'd call reactive. Looking forward to having the team back at work to get this fixed. Hope you enjoyed your Holidays...i spent mine manually syncing RTM with Outlook.

Posted 3 years ago

alec245l Pro says:

Same problem here. Not sure what triggers it but after some time Outlook stops sending changes TO RTM but still seems to accept changes FROM RTM. The workaround above doesn't work for me. Have to totally delete tasks in Outlook then re-create. Note the comment about auto sync above. This time I have only set to 'manual' sync and will see if that has any effect.

Posted 3 years ago

anthrem says:

My Outlook 2003 is as well not transferring new tasks to RTM.

Posted 3 years ago

rthompson5 says:

Neither outlook 2003 or 2010 are syncing with RTM android app. (as they were at one time). System will not allow uninstall so I am not able to re-install. When I try a "fix" via re-install process I get message saying to delete all programs that sync with Outlook.. As far as I can see I have done that.

I am stuck here and would appreciate any suggestions.

Posted 3 years ago

bentle says:

I was having the same problems (no Outlook to RTM syncing), but the instructions posted by prjh worked for me. Thanks prjh!

Posted 3 years ago

andrewski (Remember The Milk) says:

zeebacca,
We definitely monitor all the issues to find any patterns or issues we can address; that's part of the reason we ask you to submit them. :)

I see your issue report; we'll be in touch as soon as we can!

Posted 3 years ago

zeebacca says:

Thanks Andrewski but I'm all set. The rather simple solution in the following link worked for me:

http://www.rememberthemilk.com/forums/milksync/11657/

I'd like to add that in following the guidance above, I created a backup of my outlook tasks in a separate task folder in Outlook and dragged them over into the default task folder initially. Doing it this way, the tasks did not sync up to RTM. I had to export the tasks to Excel and then re-import them back to Outlook. After the import, everything synced back to RTM in full.

Posted 3 years ago

zeebacca says:

One final item I'd like to add is that I became a bit of an Evernote user during the time I couldn't sync with RTM as I need to have certain information in my pocket on the go. As luck would have it, Evernote was having sync issues today.

While trying to fix the Evernote sync issue, someone posted in their forum that running ipconfig /flushdns from the command prompt solved their problem. I likewise flushed the DNS trying to fix Evernote which was about 5 minutes before my RTM sync started working again. Maybe that had something to do with my RTM fix in addition to the plug-in enabling.

Posted 3 years ago

alec245l Pro says:

As per my note of 3 days ago - with Auto sync disabled I have been running OK now for those 3 days using only Manual sync.

Posted 3 years ago

henrikba Pro says:

Seems I have same issues as described from several users above. Below is my take/experience.
@emily and @andrewski: I will also submit this as a support query.

Background:
I run Outlook 2010 on Win7-64 against an Exchange 2003 backend + MilkSync 1.0.12 two-way manual sync.

**

Issue 1: No updates from Outlook -> RTM

For some strange reason, sometimes I end up with synchronisation issues between Outlook and Exchange (see several posts on this on Microsoft KB), making "editions" of tasks. I can click a header to display the different versions, and I see the one syncing with RTM is not what Outlook says is the latest version. This means; if I edit the most recent version in Outlook, the changes are not reflected in RTM. Even if I manually clean up the backups/editions so only one is left (and no message is shown in the task view), RTM won't get it back on track.

**

Issue 2: Sync seems to happen, but task not shown in RTM

I have inspected the log file, showing that the MilkSynk AddIn sees a new task is created when I move it from my arhive folder (temp) into my normal Tasks folder. It shows the correct number of new and completed tasks, and if I do changes, that is reflected correctly in the log too. However, the web UI of RTM shows only a small subset of these tasks.

I have previously synched these tasks from Outlook to RTM. Some of them have notes containing the [note #.....] information from last sync, some have manually edited notes where the note-tags are removed, some are completely without notes. Regardless of a fresh install of MilkSync and a completely new account on RTM, my theory is that these already "exist" some way or another in RTM, and thus are not displayed in my new account.

I will try the method from prjh with "Restore" (from RTM -> blank Outlook) to see if this helps. Otherwise, I'm probably on my way recreating abt 400 tasks + saying good-bye to my completed tasks :(

Posted 3 years ago

henrikba Pro says:

Pheeew - short report after some hours of work;

"Restore" + copy tasks back in (from an archive) didn't do it. Seems Outlook tasks are marked with some GUID so they do not sync even after a "restore". (But; I'm SADLY missing the "Restore from Outlook to RTM" option!!)

Exported all tasks (1475) to Excel, reimported into Tasks_temp, moved into Tasks (main folder) in steps of 100-200 a time, all manual syncs with MilkSync, and I'm back on track. I'll now remove everything from Outlook, uninstall MilkSync and run with RTM only for my GTD workflow.

Two major issues with the above process (Excel-export, reimport):

1) Completion date/time on completed tasks was set to the time of sync - meaning I now have more than 1000 completed tasks *today*. That's going to be interesting to sync to my iPhone... (default syncing last "two months" of completed, hehe)

2) Notes were truncated during the export/reimport. Seems only a certain lenght of notes are supported in Excel (or Outlook's export/import). So - I had to manually go through all tasks with notes and check if I was missing anything.

(I created a view in Outlook to only show tasks *with* notes, used that view on both my backup folder of original tasks with notes and the reimported (RTM-syncable) tasks with shortened notes. Ctrl-. is the outlook shortcut to move to next item, so with some heavy use of Ctrl-. and Alt-TAB to compare all tasks with notes, I could copy notes back into Outlook and sync the new tasks with "old" notes.

In an ideal world, this would have been easier :)

/Henrik

Posted 3 years ago

henrikba Pro says:

Just a nice note after running without MilkSync for some days in "production"; RTM web GUI + iPhone + e-mail tasks really work GREAT, with no sync issues so far. The iPhone app is highly recommended, and in some cases - even i.rememberthemilk.com from your PC is worth it (better overview in search result etc).

Posted 3 years ago

henrikba Pro says:

BTW: If someone ever needs to do the "export-import" trick; Excel will cut off your long notes and also mess up the completion dates. You might want to try to export to an Access file instead.

Options described on:
http://kb.iu.edu/data/agnu.html
(link courtesy of Andrew @RTM)

Posted 3 years ago

mrmeyer says:

Same problem. Thanks fort he help, exporting to Excel did the trick.

RTM needs an "import from Outlook" or some other way to start fresh.

Posted 3 years ago

benjamin.png says:

Same problem. Still not able to post from Outlook to RTM. Submitted a support ticket but still has problems.

I need a refund.

Posted 3 years ago

andrewski (Remember The Milk) says:

benjamin.png,
I see your issue report (sorry for the delay) and have written you back; check your email for details! :)

Posted 3 years ago

mgoneill says:

I have a related issue (and I have submitted a issue report), no tasks assigned to categories are syncing from Outlook. Only ones that show up on RTM are unassigned. Have tried creating lists with matching names to categories manually but no diff. Any suggestions? thanks!

Posted 3 years ago

benjamin.png says:

There seems to be a lot of issues with the new version. Will a new version be available soon or a possibility to revert to previous versions?

Posted 3 years ago

andrewski (Remember The Milk) says:

benjamin.png,
We're looking into each and every issue report to pinpoint the cause(s) of any sync problems. I've just resent our response to yours; it would be great if you could get back to me so we can figure out what's going on with yours.

mgoneill,
We'll be in touch as soon as we can!

Posted 3 years ago

reya98 says:

A quick note that might help some of you -

I'm running Windows 7 64bit + Outlook 2007 + NetCentric GTD AddIn. I discovered that MilkSync wasn't syncing any tasks (from Outlook to RTM) that had a created date more than a day old. Created in RTM, I was fine. Once synced, they seem to stay synced. It was just the first sync to get stuff over.

I followed suggestion above and discovered that exporting/importing into an Access file worked - I would assume because all the new tasks now had today's date as the created date.

That might help some of you - I've let the support team know as well. (We had a 2 month discussion going - part of which time I was MIA due to work. They've been very helpful and accommodating to help me figure this out. Thank you, Andrew.)

I will warn you that the sucky part of import/export is that I had to re-associate all the projects/subprojects/actions in the GTD AddIn after I imported everything since that information didn't seem to survive.

Hopefully that helps someone. :) If you don't hear from me, everything has stayed okay. I'll post back if I find things are falling out of sync again once the created date starts to age a bit.

Posted 3 years ago

brendan Pro says:

reya98,
Thanks for letting us know! That's definitely helpful.

Posted 3 years ago

felixtsai says:

So I had this problem as well. Fixed it (with the help of RTM) and it came back again with the new install it's happening again. Here's what fixed it the first time.

Apparently the install was disabling the RTM add-in in Outlook. For some reason tasks in RTM will still going back into Outlook but not from Outlook to RTM.

Here's what I did for Outlook 2010. Go into File/Options/Add-ins. You may notice that MilkSync for Outlook is under the disabled section. If it is, go to Manage and click on Disabled Items. In the Disabled Items menu, click on MilkSync and enable it.

You probably have to reboot Outlook at that point to load on the add-in. That fixed it the first time. I'm having some problems with it right now so I'll let you know if it works this time.

Posted 3 years ago

amingu says:

Thanks felixtsai, your method is so easy and it solve my problem.

Posted 3 years ago

mtaylorwdpro says:

Thanks, felixtsai for the clear and promising guidance. Sadly, this is not working for me either. I look forward to hearing how your ongoing investigation pans out.

Posted 3 years ago

goraleksi Pro says:

Selecting category with RTM list name is solution for tasks which added in Outlook.

Posted 3 years ago

jenava says:

I use my ipad in meetings to add tasks to RTM. I seem to have no trouble getting tasks from RTM to Outlook.

But, I actually DO my tasks while sitting at my desk and thus UPDATE them via Outlook. The updates (such as adding tags or completing a task) do not flow to RTM, or, at least, not reliably enough for me to actually use the program to do work.

I've started using the software only a month or two ago and I've NEVER gotten it to work reliably. Sometimes it will sync and then when re-syncing I get duplicates in either Outlook or RTM.

I've tried various experiments including the import/export trick as well as the add-in check (was not diabled) as well as adding "Work" as a tag to all my tasks. But I just don't have time to work as a QA Engineer for RTM's coders!

I've also emailed with the help desk (they always start by recommending I check the add-in is not disabled and then doing a recovery from RTM to Outlook which is nonsensical given the fact that this would irrevokable delete over half my task list).

At this point i'm pretty bitter that I paid for a Pro account just for this broken sync software. Has anyone actually gotten milksync to work reliably when updating from Outlook?

Posted 3 years ago

brendan Pro says:

jenava,
I'm sorry that MilkSync is not yet working reliably for you. I see you have an open issue report in our system currently, so we'll be in touch by email as soon as possible.

Posted 3 years ago

orville.jackson Pro says:

I think I've hit upon another solution for that may work for some others. In my case it had nothing to do with the "disabled add-ins" issue. The only tasks that were syncing from my Outlook were the ones located in the actual Task folder. Tasks can be located in other folders e.g., when flagging an email for follow-up it shows on my Task list, but it remains in my Inbox folder unless moved or copied to somewhere else. Instead of adding tasks by flagging emails for follow up I now simply copy them to the Tasks folder and they sync perfectly fine. Not sure if it's possible to direct RTM to sync tasks with other folders but this seems to have solved my issue. HTH someone else!

Posted 3 years ago

brendan Pro says:

orville.jackson,
That's correct, currently it's not possible to sync emails that have been flagged for followup. Even though these items show in your Task list, Outlook does not actually create a task item for them.

You can read a bit more about this, and show your support for this feature by voting for it, here.

Thanks!

Posted 3 years ago

mcclave says:

I noticed that if I edit the "Category" of the task in Outlook to match the List name, then my Outlook to RTM sync issues are resolved.

Posted 3 years ago

andrewski (Remember The Milk) says:

mcclave,
It sounds like you may have set MilkSync to sync only selected lists/categories; please contact us if you have any further problems or would like to discuss any more specifics of your situation.

Posted 3 years ago

trib22 says:

I'm getting the same issue in Outlook 2007. No sync from Outlook back to RTM.

Posted 3 years ago

brendan Pro says:

trib22,
If possible, please contact us via email as well. We'd love to take a closer look at what's going on in your situation.

Thanks!

Posted 3 years ago

kouyanet says:

I've submitted a report, but just thought I'd post here to. I am using Outlook 2010 on Win 7 and RTM sync currently won't sync in either direction. I've not tried the solutions listed above because I moved over to RTM to save me time, not to give me something else to faff around with.

Looking forward to a response from the team.

Posted 3 years ago

brendan Pro says:

kouyanet,

I see your report in our system and I've responded via email. Thanks!

Posted 3 years ago

bmager81 says:

First, thanks to all for your help in this forum. I had tried EVERYTHING to get milksync to work correctly. And I thought I had it right when I went through the steps that prjh suggested, but it still didn't work in the end.

Then I realized the problem. I use ALOT of categories in Outlook. I also have RTM set to only sync my list I've called "work". When I did the steps above the one task that synced changed its category to "work" even though that was never a catagory I set in outlook.

Anyway, somehow RTM must have erased all my categories in outlook (annoying) and added "work". But, by changing the way I used them a little and categorizing every task to "work" everything syncs beautifully!! I just need to find a way to have outlook always categorize my tasks or remember to do so myself!

Hopefully this might help anyone else still trying to resolve the issue.

Posted 3 years ago

This topic has now been closed automatically due to a lack of responses in the past 90 days.