Welcome!  English (US) Language Switcher

2.0 Widgets Not Updating

rmorgangriffin says:

Love the update, but I've noticed that my list widgets haven't been updating.

Within the program, everything works fine and updates normally. But when I go back to the home screen -- after adding an item or checking one off -- the widget list is unchanged.

Manually refreshing within the program has no effect. The widgets will stay static for hours at least. So far, the only way to get the widgets to update is to restart the phone.

Currently, the widgets aren't doing me much good, since they reflect data that's hours out of date.

Any ideas?

Posted at 3:39pm on October 19, 2011

rmorgangriffin says:

Wait -- a correction.

It seems that adding a task *does* trigger an update on the widget.

It's just completing or editing an existing task that does not.

Posted 3 years ago

brendan Pro says:

Hi rmorgangriffin,
If you haven't done so already, would it be possible to delete these widgets and re-create them? You can delete them by long-tapping and dragging them to the trash, and re-create them by pressing Menu, then Add, then Widgets.

If you're finding that they are still not updating, can you contact us so we can get some additional details from you?

Thanks!

Posted 3 years ago

rmorgangriffin says:

Yeah, that doesn't work. Strangely, even after deleting the old widget list and making a new one, already-completed tasks reappeared as not-completed.

Posted 3 years ago

brendan Pro says:

rmorgangriffin,
Thanks for getting back to me with that. I see the support request you submitted in our system, and we'll be in touch via email as soon as possible.

Thanks!

Posted 3 years ago

gregorymeister says:

Having the exact same problem - Droid x

Posted 3 years ago

chrisg Pro says:

I'm having the same problem on a Droid 2.

Posted 3 years ago

goraleksi Pro says:

I'm having the same problem on a HTC Desire.

Posted 3 years ago

rmorgangriffin says:

Sorry to see I'm not the only one. Brendan was very helpful and escalated me to an engineer.

It's a shame, because I've come to really rely on those widgets. Wondering if I should roll back to the previous version until this gets fixed.

Posted 3 years ago

katarihug Pro says:

Hi - I am seeing this in a list using the dueBefore:Now filter. The reminder will ring for the task but the task doesn't appear in the widget. If I click on the widget to view the list the task is visible but when I go back to the home screen the task is not visible.

Posted 3 years ago

smh8 Pro says:

Just to add I'm having identical problem on Droid X. I'll go through the contact page but it sounds systemic rather then isolated.

Did delete widget and did try different widgets, problem is consistent across all.

Posted 3 years ago

brendan Pro says:

Hi katarihug,
Would you be able to contact us as well so we can take a closer look at this?

Thanks!

Posted 3 years ago

katarihug Pro says:

Hi Brendan - I have logged a docket.

Posted 3 years ago

emily (Remember The Milk) says:

Thanks for everyone's reports!

We've found that there's a bug in some Motorola devices that means the widgets don't update correctly in some circumstances. :( We're still trying to figure out a fix for this, so I'll let you guys know as soon as I have an update.

If you're experiencing a similar issue and you're not using a Motorola device, you might've stumbled across a different bug -- please make sure to contact us as we'd love to get more details from you.

Thanks!

Posted 3 years ago

emily (Remember The Milk) says:

The widgets should now update correctly on Motorola devices running Gingerbread, as of version 2.0.2. (We bought a Motorola device so we could find out what was happening... :)

If anyone is still experiencing widget issues with this latest update, please be sure to let us know. Thanks!

Posted 3 years ago

rmorgangriffin says:

Unfortunately, the widgets still aren't updating with the new 2.0.2 update on my Droid X2. The same problem as before. Already sent an email.

Posted 3 years ago

rmorgangriffin says:

Just got 2.0.3 and it works! Thanks so much.

Posted 3 years ago

This topic has now been closed automatically due to a lack of responses in the past 90 days.